Turnipsoft Forums

Full Version: Freda interrupts audio on Bluetooth
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Love Freda!  Use it on my laptop for a lot of reading.  For the price, it's a gift to the world.  Thank you!

I've hit a weird and consistent problem on Windows 10.  If I am playing audio in another app on the same Windows laptop (tested with Spotify app and a YouTube video through a browser) and I'm listening to the audio through a Bluetooth speaker, then every time I open a Freda book, the audio - say, music - goes silent and cannot be heard.  If I switch away from Freda, music is heard again.  

Unfortunately, this kills my ability to read in Freda while streaming music (or any other audio) to a room speaker.  This has forced me to use alternative ebook readers (none of which are as good!) for this scenario.

More clues:
  • Freda does not silence the music if I'm using the laptop's speakers - only when using an external Bluetooth speaker connected to the laptop.
  • Silencing does not occur when I'm looking at Freda bookshelf, only when viewing inside a book in Freda.
  • Silencing only happens when Freda is the active app.  If Freda is open in the background, music can be heard.  But as soon as I "Alt-Tab" (or otherwise switch) to Freda, music silences.  If I switch to any other app (or Windows desktop), music comes through fine.  Even if Freda is active in book-reading mode (i.e. music is silenced) and I just Alt-Tab to show the other open Windows apps, the music resumes while the Alt-Tab overlay is active.
  • Freda's text-to-speech function (which I don't use, but tested for this) works through the Bluetooth speaker.  The speech is heard fine, even as other audio playing in another app is silenced.  This leads me to wonder if, on Bluetooth, somehow Freda is too aggressive or exclusive in taking control of the audio stream?  It silences the other apps even when no speech is being played in Freda.  (My ideal would be: Freda never interrupts audio stream unless text-to-speech is active, and when text-to-speech is active, other audio sources are only turned down and mixed in, not silenced.  This way I could listen to text-to-speech with music in the background.) 
  • Doesn't matter if using Freda free version or Freda Plus.
  • Doesn't matter if Freda is full-screen or windowed.
  • If I open same book in Calibre, audio issue does not occur (i.e. I can hear music while reading in Calibre -- didn't test text-to-speech in Calibre).
  • I couldn't find any controls in Freda to prevent / exclude / turn off text-to-speech feature, which I'm guessing is involved.
All the above is consistently true, but check out this one specific instance I ran into:
  1. Play Spotify on laptop speakers.
  2. Load Freda and read book (no problem so far).
  3. Leave Freda (can't remember if I closed it or just went to a different app).
  4. Turn on Bluetooth in Windows and redirect Spotify music to Bluetooth speaker.
  5. Come back to Freda in book-reading mode -- Audio continues to play!  (very unusual)
  6. Alt-Tab away from Freda, music continues to play (as normal)
  7. Alt-Tab back to Freda -- as usual, music is silenced.

Thanks for any attention you're able to give to this.  Platform details below.

Jon Whitener

Seeing this issue on this system:

Acer Aspire 5 laptop
Model A515-54-597W 
Intel Core i5-8265U CPU, 8 GB RAM

Windows 10 Home 64-bit
Version 1909
OS Build 18363.1139

Other specs on MicroCenter listing:
(10-25-2020, 02:45 PM)jwhitener Wrote: [ -> ] every time I open a Freda book, the audio - say, music - goes silent and cannot be heard.  If I switch away from Freda, music is heard again.  

Thank you for reporting this problem.  I will look into it.  I have to admit, the behaviour of Windows audio is something that always perplexes me, so I am not sure what I will be able to do about this, but I will do what I can.
(10-27-2020, 09:59 AM)jim_chapman Wrote: [ -> ]
(10-25-2020, 02:45 PM)jwhitener Wrote: [ -> ] every time I open a Freda book, the audio - say, music - goes silent and cannot be heard.  If I switch away from Freda, music is heard again.  
I've spent some time looking into this, and I can't reproduce the issue on any of my test machines, having tried with a couple of different bluetooth speakers.  So I am a bit at a loss.

One thing you could try: on the settings screen, tap the 'controls' link, and in that screen find the 'use media buttons' setting, and make sure that it is set to 'no'.