Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unable to Connect to calibre Server Using SSL with Self-Signed Certificate
Hey All-

I just downloaded Freda and tried to connect it to my established and accessible calibre server and receive an error message rather than a catalog after entering my login info. The message just says "Failed to donwload"... I'm assuming this has something to do with the fact that I'm using a Self-Signed Certificate for SSL. I have no issue reaching my calibre server in a web browser, but I must agree upon first connection to "Proceed" past the security warning because the certificate is not issued by a trusted authority. I believe this is where Freda is failing, but that is only my assumption. Also, I don't believe this should matter, but calibre is running on a non-standard port, which I inserted in the appropriate box in Freda.

The only log file I found at AppData\Local\Packages\5957Turnipsoft.freda_ypmq2qh89vmny\LocalState\Freda only seems to contain one associated entry:
2023-05-23 08:55:01.739: INFO: OpdsCatalogBookSource.Navigate callback: download has failed 'https://calibre.{someDomain}.com:{Port}/opds'

This message doesn't really give much to go by. Just to reiterate, I have no issues accessing the calibre server via a web browser on the same computer as the server, or from other hosts on the network, or even over the Internet. I have tried to connect with Freda from multiple hosts as well, to no avail.

Thanks in advance for your help!

Messages In This Thread
Unable to Connect to calibre Server Using SSL with Self-Signed Certificate - by TheKidzKid - 05-23-2023, 04:14 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)