Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issues trying to connect to calibre server
(01-05-2019, 05:43 PM)jim_chapman Wrote:
(01-04-2019, 02:25 PM)cnicu Wrote: [...]


Sorry about the problem with the Calibre setup.  The issue is that Freda assumes that 'path' the Calibre URL consists only of '/opds' (which is the default behaviour of Calibre, I think).  You're using a customised path '/calibre/opds' and this is causing Freda to get confused.  I will take a look at the code, and see if I can make it behave better in this case.

But in the meantime, you can get the result you need by instructing Freda to use a generic OPDS source, rather than a Calibre-customised one.  You do that by creating an OPDS source whose name does not include 'Calibre'.  Then you will be able to directly specify the URL you need:
and you will also want to supply the 'search' URL:{0}

Please post again (or email if that does not work for you.

Hi Jim!
Thanks for your support. Didn't know it could be solved so easily . Smile

Yes, it worked fine apart from the small fact that the search URL has to be{0} 

(i.e. only one "opds" instead of ".../opds/opds/..." that you initially suggested.)

By the way, I have bought the add free version of freda after this calibre stuff worked out. Angel

Best regards,

Messages In This Thread
RE: Issues trying to connect to calibre server - by cnicu - 01-16-2019, 09:59 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)